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This appendix shows how to use Comprehensive Meta-Analysis (CMA) to perform a meta-analysis using fixed and random effects models.
We include three examples

Example 1 ─ Means in two independent groups

Example 2 ─ Binary data (2x2 tables) in two independent groups

Example 3 ─ Correlational data

To download a free trial copy of CMA go to www.Meta-Analysis.com
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Example 1 ─ Means

Start the program and enter the data
· Start CMA

The program shows this dialog box.
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· Select Start a blank spreadsheet
· Click OK
The program displays this screen.
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Insert column for study names
· Click Insert > Column for > Study names
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The program has added a column for Study names.
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Insert columns for the effect size data
Since CMA will accept data in more than 100 formats, you need to tell the program what format you want to use.

You do have the option to use a different format for each study, but for now we’ll start with one format.
· Click Insert > Column for > Effect size data
[image: image6.png]Ble Edt Format lew | Insert Identfy Tooks Computational options Analyses. telp

Run analyses + % i EDIROM  Study names B2+ 82 @
Subgroups WEhinstudy [

Comprison names; & H 1 J

Blark column
Copy of selected column

Study name.

Outcome names

).
'— Hankron

Time point names
P Hankraws

B Copy of st ron(s) M
Woderstor varabe

»:





The program shows this dialog box.
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· Click  Next
The dialog box lists four sets of effect sizes.
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· Select  Comparison of two groups, time-points, or exposures (includes correlations
· Click Next
The program displays this dialog box.
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· Drill down to

· Continuous (means) 
· Unmatched groups, post data only 
· Mean, SD and sample size in each group

· Click  Finish
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The program will return to the main data-entry screen.
The program displays a dialog box that you can use to name the groups.
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· Enter the names Treated and Control
· Click OK
The program displays the columns needed for the selected format (Means and standard deviations).  It also labels these columns using the names Treated and Control.
You will enter data into the white columns (at left).  The program will compute the effect size for each study and display that effect size in the yellow columns (at right).  
Since you elected to enter means and SDs the program initially displays columns for the standardized mean difference (Cohen’s d), the bias-corrected standardized mean difference (Hedges’s G) and the raw mean difference.  You can add other indices as well.
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Enter the data

· Enter the mean, SD, and N for each group as shown here

· In the column labeled Effect direction use the drop-down box to select Auto  
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(“Auto” means that the program will compute the mean difference as Treated minus Control.  You also have the option of selecting “Positive”, in which case the program will assign a plus sign to the difference, or “Negative” in which case it will assign a minus sign to the difference.)

The program will automatically compute the effects as shown here in the yellow columns.
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Show details for the computations
· Double click on the value 0.540
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The program shows how this value was computed.
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Set the default index to Hedges’s G
At this point, the program has displayed three indices of effect size – Cohen’s d, Hedges’s G, and the raw mean difference.
You have the option of adding additional indices, and/or specifying which index should be used as the “Default” index when you run the analysis.  
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· Right-click on the column for Hedges’s G

· Click Set primary index to Hedges’s g
Run the analysis

· Click  Run Analyses
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The program displays this screen.  
· The default effect size is Hedges’s G

· The default model is fixed effect
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The screen should look like this.
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We can immediately get a sense of the studies and the combined effect.  For example,

· All the effects fall on the positive side of zero, in the range of 0.205 to 0.763  
· Some studies are clearly more precise than others.  The confidence interval for Graham is about four times as wide as the one for Manning, with the other three studies falling somewhere in between  
· The combined effect is 0.307 with a 95% confidence interval of 0.234 to 0.380
Customize the screen 

We want to hide the columns for the lower and upper limit and z-value.
· Right-click on one of the “Statistics” columns
· Select  Customize basic stats
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· Assign check-marks as shown here
· Click OK
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The program has hidden some of the columns, leaving us more room to work with on the display.
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Display weights

· Click the tool for Show weights
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The program now shows the relative weight assigned to each study for the fixed effect analysis.  By “relative weight” we mean the weights as a percentage of the total weights, with all relative weights summing to 100%.

For example, Madison was assigned a relative weight of 6.75% while Manning was assigned a relative weight of 69.13%.
Compare the fixed effect and random effects models
· At the bottom of the screen, select Both models
· The program shows the combined effect and standard error for both fixed and random effects models

· The program shows weights for both the fixed effect and the random effects models
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Impact of model on study weights
The Manning study, with a large sample size (N=1000 per group) is assigned 69% of the weight under the fixed effect model but only 26% of the weight under the random effects model. 
This follows from the logic of fixed and random effects models explained earlier.

Under the fixed effect model we assume that all studies are estimating the same value and this study yields a better estimate than the others, so we take advantage of that.  
Under the random effects model we assume that each study is estimating a unique effect.  The Manning study yields a precise estimate of its population, but that population is only one of many, and we don’t want it to dominate the analysis.  Therefore, we assign it 26% of the weight.  This is more than the other studies, but not the dominant weight that we gave it under fixed effects.
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Impact of model on the combined effect

As it happens, the Manning study has a low effect size.  Under the fixed effect model, where this study dominates the weights, it pulls the effect size down to 0.31.  Under the random effects model, it still pulls the effect size down, but only to 0.46.
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Impact of model on the confidence interval

Under fixed effect, we “set” the between-studies dispersion to zero.  Therefore, for the purpose of estimating the mean effect, the only source of uncertainty is within-study error.  With a combined total near 1500 subjects per group the within-study error is small, so we have a precise estimate of the combined effect.  The standard error is 0.037.
Under random effects, dispersion between studies is considered a real source of uncertainty.  And, there is a lot of it. The fact that these five studies vary so much one from the other tells us that the effect will vary depending on details that vary randomly from study to study.  If the persons who performed these studies happened to use older subjects, or a shorter duration, for example, the effect size would have changed.

While this dispersion is “real” in the sense that it is caused by real differences among the studies, it nevertheless represents error if our goal is to estimate the mean effect.  For computational purposes, the variance due to between-study differences is included in the error term.  In our example we have only five studies, and the effect sizes do vary.  Therefore, our estimate of the mean effect is not terribly precise, as reflected in a standard error of 0.112, which is about three times that of the fixed effect value.  
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What would happen if we eliminated Manning?  
Manning was the largest study, and also the study with the smallest effect size.  To better understand the impact of this study under the two models, let’s see what would happen if we were to remove this study from the analysis.

· Right-click on Study name
· Select Select by study name
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The program opens a dialog box with the names of all studies.
· Remove the check from Manning
· Click OK
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The analysis now looks like this.
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For both the fixed effect and random effects models, the combined effect is now close to 0.54.  
· Under fixed effects Manning had pulled the effect down to 0.31
· Under random effects Manning had pulled the effect down to 0.46
· Thus, this study had a substantial impact under either model, but more so under fixed than random effects
· Right-click on Study name
· Add a check for Manning so the analysis again has five studies
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Additional statistics
· Click Next table on the toolbar
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The program switches to this screen.
The program shows the point estimate, standard error, variance, and confidence interval.  These are the same values that had been shown on the forest plot.
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· Under fixed effect the combined effect is 0.307 with standard error of 0.037 and 95% confidence interval of 0.234 to 0.380  
· Under random effects the combined effect is 0.462 with standard error of 0.112 and 95% confidence interval of 0.243 to 0.682
Test of the null hypothesis
Under the fixed effect model the null hypothesis is that the common effect is zero.  Under the random effects model the null hypothesis is that the mean of the true effects is zero.  

In either case, the null hypothesis is tested by the z-value, which is computed as G/SE for the corresponding model.
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For the fixed effect model
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For the random effects model



[image: image37.wmf]*

0.462

Z==4.127

0.112


In either case, the two-tailed p-value is < 0.001.

Test of the heterogeneity

The null hypothesis for heterogeneity is that the studies share a common effect size. 

The statistics in this section address the question of whether the observed dispersion among effects exceeds the amount that would be expected by chance.  
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The Q statistic reflects the observed dispersion.  Under the null hypothesis that all studies share a common effect size, the expected value of Q is equal to the degrees of freedom (the number of studies minus 1), and is distributed as Chi-square with df = k-1 (where k is the number of studies).
· The Q statistic is 20.64, as compared with an expected value of 4
· The p-value is < 0.001  
As discussed in the text, the decision to use a random effects model should be based on our understanding of how the studies were acquired, and should not depend on a statistically significant p-value for heterogeneity.  In any event, however, this p-value tells us that the observed dispersion cannot be attributed to random error, and there is real variance among the effects.  A fixed effect model would not fit the data.

Quantifying the heterogeneity

While Q is meant to test the null hypothesis that there is no dispersion across effect sizes, we want also to quantify this dispersion.  For this purpose we would turn to I-squared and tau-squared.
· To see these statistics, scroll the screen toward the right
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· I-squared is 80.6, which means that 80% of the observed variance between studies is due to real differences in the effect size.  Only about 20% of the observed variance would have been expected based on random error.

· Tau-squared is 0.047.  This is the “Between studies” variance that was used in computing weights.
The Q statistic and tau-squared are reported on the fixed effect line, and not on the random effects line.  
These values are displayed on the fixed effect line because they are computed using fixed effect weights.  These values are used in both fixed and random effects analyses, but for different purposes.

For the fixed effect analysis Q addresses the question of whether or not the fixed effect model fits the data (is it reasonable to assume that tau-squared is actually zero).  However, tau-squared is actually set to zero for the purpose of assigning weights.

For the random effects analysis, these values are actually used to assign the weights. 
Return to the main analysis screen

Click Next table again to get back to the other screen.
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Your screen should look like this.
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High-resolution plots

To this point we’ve used bar graphs to show the weight assigned to each study.  

Now, we’ll switch to a high-resolution plot, where the weight assigned to each study will determine the size of the symbol representing that study.

· Select Both models at the bottom of the screen

· Unclick the Show weights button on the toolbar

· Click High-resolution plot on the toolbar
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The program shows this screen.
· Select Computational options > Fixed effect
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· Select Computational options > Random effects
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Compare the weights.  
In the first plot, using fixed effect weights, the area of the Manning box is about 10 times that of Madison.  In the second, using random effects weights, the area of the Manning box is only about 30% larger than Madison.
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Compare the combined effects and standard error.
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In the first case (fixed) Manning is given substantial weight and pulls the combined effect down to 0.307.  In the second case (random) Manning is given less weight, and the combined effect is 0.462.

In the first case (fixed) the only source of error is the error within studies.  The standard error of the combined effect is 0.037 and the confidence interval about the combined effect is relatively narrow.  In the second case (random) the fact that the true effect varies from study to study introduces another level of uncertainty to our estimate.  The standard error of the combined effect is 0.112, and the confidence interval about the combined effect is about three times as wide as that for the fixed effect analysis.
· Click File > Return to table
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The program returns to the main analysis screen.
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Computational details
The program allows you to view details of the computations.
Computational details for the fixed effect analysis

· Select Format > Increase decimals on the menu
This has no effect on the computations, which are always performed using all significant digits, but it makes the example easier to follow.
· On the bottom of the screen select Fixed
· On the bottom of the screen select Calculations
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The program switches to this display.
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For the first study, Madison
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The weight is computed as 
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where the second term in the denominator represents tau-squared, which has been set to zero for the fixed effect analysis.
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and so on for the other studies.  Then, working with the sums (in the last row)
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· To switch back to the main analysis screen, click Basic stats at the bottom
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· These are the same values presented here
Computational details for the random effects analysis

Now, we can repeat the exercise for random effects.
· On the bottom of the screen select Random
· On the bottom of the screen select Calculations
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The program switches to this display.
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For the first study, Madison



[image: image73.wmf]RawDifference =410-360=50




[image: image74.wmf](

)

(

)

+

=

+-

22

Pooled

(100-1)(90)(100-1)(95)

SD = 92.534

1001002




[image: image75.wmf]50

0.5403

92.534

d

==




[image: image76.wmf]=++=

+

2

110.5403

0.1440

1001002*(100100)

d

SE




[image: image77.wmf]æö

=

ç÷

èø

3

J = 1 -0.996

4 * 198 - 1




[image: image78.wmf]==

0.996*0.54030.5383

G




[image: image79.wmf]==

0.996*0.14400.1434

G

SE




[image: image80.wmf]==

22

0.1434.0206

G

SE


The weight is computed as 
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where the (*) indicates that we are using random effects weights, and the second term in the denominator represents tau-squared.
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and so on for the other studies.  Then, working with the sums (in the last row)
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(Note – The column labeled Tau-squared Within is actually tau-squared between studies, and the column labeled Tau-squared Between is reserved for a fully random effects analysis, where we are performing an analysis of variance).

· To switch back to the main analysis screen, click Basic stats at the bottom

On this screen, the values presented are the same as those computed above.
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This is the conclusion of the exercise for means.
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